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Arduino in Education
A journey into STEAM
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IXD Is a discipline
looking at the
interaction between
[non] humans by means
of digital artifacts
[products and servicesl.
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People use
platforms to learn
and create things.
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How replicable is
this?
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THE FIRST Ul


http://www.youtube.com/watch?v=l4zwKJhjRNo






https://docs.google.com/file/d/1VoX3g7l1TZR9aP2PuS_uPYiicTVIgIY6/preview




What is Arduino?
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32-bit Arm" Cortex®- M4

microcontrollex CAN BUS

GNT%

DICITAL - PWM~

UNO

POWER ANALOG IN

OO

DCDC buck
converter 5V

USB-C"

connector OP AMP

12-bit DAC

Debug SWD

header 10 pin

Wi-Fi® and Bluetooth®
capabilities

GND

DICGITAL (PWM~

O

12x8 on-boaxd
LED matrix

POWER ANALOC IN
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https://docs.google.com/file/d/1Y-v71M5QAlf4yD_PrHA5CZ8G3sBc7Tgq/preview

& & & Blink | Arduino IDE 2.0.0-rc9

Q e @ Arduino Zero (Native USB Port)
DE

EBUG Blink.ino
iz )
D> Arduinov 3 [3] 26 void setup() {
27
2 ¥ * 9 0O 28 pinMode (LED_BUILTIN, OUTPUT);
R 29 }
~ THREADS 5
30
R... PAUSED ON BREAKPOINT 31
32 void loop() {
a’a e 33 digitalWrite(LED_BUILTIN, HIGH);
S S 34 delay(200);
loop@0x00002... Blink.ino ) = 35 digitalWrite(LED_BUILTIN, LOW);
main@0x0000... main.cpp &R 36 delay(200);
37 }
\ VARIABLES 3
> Local
> Global
' WATCH

v BREAKPOINTS

@ Blink.ino

@ Blink.ino

> CORTEX PERIPHERALS

Cuartielles - 2024 - — on DE/ rED




.. the Arduino IDE is
downloaded once
every 2'5 seconds ...
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PROFESSION EDUCATION STORE Q Search on Ard c m

HARDWARE SOFTWARE cLouD DOCUMENTATION ¥ COMMUNITY ¥ BLOG ABOUT

WHAT IS ARDUINO? ARDUINO

DAY 2023
£J0
v

\O

R

N, S
Let's celebrate
together!

Build your UNO and synth
BUY AN ARDUINO ‘ Check the program of Arduino Day 2023 to make classic sounds
and connect with incredible stories from the 80s
and projects
LEARN ARDUINO .

Go back to the'future!

Discover more! Check it out now!

ARDUINO IN THE CLOUD @@

% Arduino PLC IDE
VINEYARD PEST

ARDUINO . ‘ Bring IEC 61131-3 programming
[TC NG

m languages to Arduino N T NG W
+
1 o Check it out now! ARDUINO PRO

Develop your code in the cloud

and build smart loT projects!
Cuartielles -

® Help




TRANSMITTER

RECEIVER



https://docs.google.com/file/d/1De9Et78-43t8xUYdbLP6L35Ta8A1y8zF/preview

.. over 60.000.000
people visit the Arduino
website yearly ..

Cuartielles - 2024



THE KEY ASPECT?






But we came to talk
about ..

Cuartielles, 2024



... pedagogical models (and reflections)

e Different ways of approaching technical materials in class.
e Mixing technology with other materials.
e Maximising outreach.

e Thinking about limitations.

MALMO e .
l (LConversey e



The same way we were
teaching, other teachers
decided to use this

platform for STEAM
teaching.

Cuartielles - 2024



STEAM: Science
Technology,
Engineering, Arts, and
Math

Cuartielles - 2024
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2010 MEXICO FARO DE ENTE










2014 - 2016 SPAIN - ETOPIA









2013 - 2019 SPAIN



//Declare the capacitive sensok ;
CapacitiveSwitch sensor=CapacitiveSwy

S

void setup(){ .’

//initialize the capacitive s&nhsor. Threshold is 400
sensor.config(400);

//initialize the servo motor
pull.attach(9);

}
void loop(){
if(sensor.getState()){
Cuartielies - 2024 //1f the capacitive sensor is touched, pull the st
pull.write(0);




BLOCK 1 - PROGRAMMING BLOCK 2 - SPORTS

BLOCK 3 - MAGIC BLOCK 4 - ROBOTS

/1(] )



https://docs.google.com/file/d/1d8i5PWDcBRzqu8Hi7l-p_wg3eFmeNOM5/preview
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https://docs.google.com/file/d/1rBW2AXfHJuL4f0Jw18_Pg90rbGspaOea/preview

% pelars.

(CREATE/CAPTURE) What new data analytics can be
derived from the hands-on learning of STEM subjects?

‘ LEARNING
DESIGNED REALTIME ANALYTICS
ENVIRONMENT FEEDBACK and reporting
furniture, architecture and for learning support  :
labware

(ANALYZE/REASON) How can
these data analytics be used to
understand and support
practice-based learning?

w/ embedded sensors 0 -

SOFTWARE &
HARDWARE KIT
w/ integrated analytics

(VISUALIZE) How can we develop visualization
tools that combine learning analytics data from
rich multi-modal sensors and students
self-documentation to  provide  meaningful

2016 EU PROJECT
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What | really wanna
KNow IS ...
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What is the impact of
the Arduino platform in
teaching? Does it help
students learn about
embedded technology?

Cuartielles - 2024



REPORTE SEMANA #19
No. 11 de 12

Capacitacién de misién espacial del
23 al 26 de Mayo de 2022

CION BREVE
Actividades desarrolladas semanalmente para el proyecto:
Aguascalientes al espacio 2022.

Contigo. 100

Evidencias de visita

ooz 2. EJ.-bsQ&j 0
] \
i X

nvernadero
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The survey process.

Teacher Student Project Report and
Education Education Building Presentation

/

First student survey Second student survey

MALM6 artielles -
lll UNIVERSITY Crites 2028






GOBIERNO DEL ESTADO




Self-reported STEAM knowledge

Microcontrolers

* %k

Micro_C (Arduino) Micro_ Bloks
* Pre mPost

1 MALMO **P-value <.01; ** P-value <05 e o
[ uNiversiTY



Test of STEAM competence

%X %k
* %k

Electronic Robotic Communication
™ pre mpost

MALMO **P-value <.01; ** P-value <.05 Cuartielles - 2024
(U universiTy
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List of open questions to consider

e Classes at multiple speeds

e [absvs. personal kits: when and where?

e Kitsvs. toolboxes: what is best?

e Al specific. dependency layers (C-NN-platforms)
e Guided vs. exploratory courses

e [EXxpectations: And when novelty has wear off?

MAI.M6 uartielles -
l (LConversey e



Let's wrap this up
In style.



There will always be
people looking into
creative uses of
technology.

Cuartielles - 2024



JAKARTA LIGHT INSTALLATION


http://www.youtube.com/watch?v=SCEsCibAA98

Thanks 0 ©
for coming by!




Thanks 0 ©
for coming by!
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http://www.youtube.com/watch?v=OuXxlObME_4
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https://docs.google.com/file/d/1JzJ0FM49U_F0yxT9Ax1S-FygnIF4RtJZ/preview
https://docs.google.com/file/d/1WWO4sdHjBvbSleMxsnz2GiGdKlkiXX2w/preview




Image Caption: Kelly Heaton, 2017. Left: “Donald Trump (The Big Hack).” Center: “Vladimir Putin (The Operational Amplifier).”
Right: “Hillary Clinton (The Big Shock).” All works are oil on canvas, 18” x 18” x 1.5.”
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Image caption: Kelly Heaton, “Finally a chirping cricket,” 2012. Notebook sketch from my struggle to learn electrical engineering.



Image caption above: Kelly Heaton, “Printed Circuit Bird (Peach Bird),” 2020. Custom analog electronics and printed circuit board
with a clear solder mask, which makes the copper appear peach-colored. 7” x 9” x 1.5”
Image caption below: Kelly Heaton, “Schematic for Deep Fake Birdsong,” 2020



Image caption above: Kelly Heaton, “Big Pretty Bird,” 2019. Custom analog electronics and printed circuit board with green
soldermask, white silkscreen, and ENIG plating. 18” x 24” x 1”

Image caption below: Kelly Heaton, Transparent Bird, 2019. Freeform analog electronics inside of laser cut and folded mylar. 5” x
8IIX 3//



"n

Image caption above: Kelly Heaton, “Sounds of Another Time (Rising Dragon)",” 2021. Analog electronics, printed circuit boards,

and silkscreen on fabric-covered panel. Unique series of 6 mixed media electronic artworks with one AP. 23.5” x 37.5x 2”
Image caption below: Kelly Heaton, “The Tree of Life,” 2022. 13” x 9” x 1”. Artist’s proof for an edition not yet released





https://docs.google.com/file/d/1vQOmQ5CnNjudpbssEJV-8B_u5YMikEWr/preview
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ARDUINO




Arduino Uno

connected robots and other educational machines
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Workshop materials

® micro-servo motor working at 3V3

e greenLED

e 2 X push-button or tactile switch

e 1Xxjoystick

e 1Xxpiezo buzzer

e USB cable to use between the Arduino board and a PC
® jumper wires

breadboard

e crafting materials (cardboard, glue, paint, tape, scissors, etc)

MAI.M6 artielles -
lll UNIVERSITY Cunrees - 202
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LED (Light Emitting Diode)

.




Indicates
Cathode

Cathode (-)

87



Resistors













ometers / Joysticks

otent
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USB Cable




=9 egme » 0

-> Short pin to GND

-=> Long one to pin 10

o
=
[
=]
[=]
@
<




-> Connect your board to
the PC

-> Open the Arduino IDE




Process

e Install the Arduino IDE 2.x.x

e Install the core for the Arduino Uno R4, which is quite new
e Trythe different features of the board

e Connect external parts

e Build a small interactive machine

e |[ifthereistime] Connect to the Arduino Cloud

MALMé uartielles -
l (Lonversy e



-> Select your board
Arduino Uno R4

-> Selecciona el puerto
Tools > Port > Arduino Uno

=> Abre el ejemplo
File > Examples > Edulntro > courseware > workshop_1h > Blink

- Descarga el codigo a tu placa



RETO
Modifica el programa para que parpadee mas rapido / despacio

OBJETIVOS
Encuentray selecciona tu placa

7

Abre ejemplos

Descarga cddigo a tu placa
Modifica un programa

Usa un LED

N 2 207

100



Desconecta la placa
del ordenador

101
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LED externo
resistencia en

= Anadamos un
serie

-> Conectado al
pin 10
- Usando una



RETO
Cambiael LED al pin 5

OBJETIVOS

-

N

Tu primer circuito conectado a Arduino
Use de una breadboard
Uso de resistencias

Uso de mas pines en la placa

103



Desconecta la placa
del ordenador

104



2. Hola Mundo!

-=> Saluda a tu motor!

- Prepara tu motor con uno de
los apliques para que puedas
Ver Como se mueve




-=> Conecta el motor a

Arduino usando cables =
«« ARDUINO

l!‘\e-ti’-g ;CII]
Rojo > 5V
Negro > GND

Blanco > 10



| | 2. Hola Mundo!

-> Conecta la placa al ordenador

=» Comprueba que placa y puerto
estén bien seleccionados

=> Abre el ejemplo
File > Examples > Edulntro >
NN courseware > workshop_1h >

Servo

I I I |



2. Hola Mundo!

RETO

Cuales son los mayores / menores valores que puedes usar para
posicionar el motor?

OBJETIVOS
=> Conecta un servo motor
=> Programa un motor para que se mueva

- Combinando 3 de estos, podrias hacer un brazo robético!

108



Desconecta la placa
del ordenador

109
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HHH

-> Conecta la placa al ordenador

=» Comprueba que placa y puerto
estén bien seleccionados

=> Abre el ejemplo
File > Examples > Edulntro >
courseware > workshop_1h >
Melody




RETO
Modifica tu cancidn

OBJETIVOS
-> Mdsica!

- Piezoy melodias

=> Colabora con otros y crea una orquesta!

112



Desconecta la placa
del ordenador

113



= ARnade un
boton a tu
circuito

Rojo > 7
Negro > GND




HHH

-> Conecta la placa a tu
ordenador

=» Comprueba que placa y puerto
estén bien seleccionados

- Abre el ejemplo
File > Examples > Edulntro >
courseware > workshop_1h >
MelodyButton




OBJETIVOS
-> Mdsica!

-> Piezoy melodias

—=> Uso de sensores

116



Desconecta la placa
del ordenador

117



5. Sefiales analogicas

- Conecta el
potenciometro
a tu placa

Rojo > 5V (3V3)
Negro > GND
Otro > Senal Fritzing




5. Sefiales analogicas

-> Conecta la placa al ordenador

=» Comprueba que placa y puerto
estén bien seleccionados

=> Abre el ejemplo
File > Examples > Edulntro >
courseware > by_topic >

Potentiometer



5. Sefiales analogicas

RETO

Prueba la funcidn readStep(int steps) y explica como funciona.
Conecta el LED a la placa para ver como cambia la intensidad.

OBJETIVOS
- Lee sefiales analdgicas

- Conoce diferentes tipos de sensores analdgicos

=> Manda valores por el puerto serie

120



Desconecta la placa
del ordenador

121



